1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[YukiTheater] Black Screens/Can't See Videos

Discussion in 'Help and Support' started by WinterPhoenix96, Dec 30, 2015.

  1. WinterPhoenix96

    WinterPhoenix96 Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    511
    Likes Received:
    150
    You don't have Adobe Flash Player installed or up to date, or you're trying to watch a video on YouTube with IPv6 enabled!

    Steps To Install Adobe Flash Player for GMod
    1. Go here: https://get.adobe.com/flashplayer/otherversions/
    2. Download Adobe Flash Player using that page for NPAPI/FireFox (uncheck all "Optional offers")
    3. Install Adobe Flash Player using the installer you just downloaded
    4. Restart Garry's Mod
    5. Rejoin the server
    If that doesn't work... Steps To Disable IPv6
    1. Assuming you're running Windows, See the Microsoft Knowledgebase Article on How to Disable IPv6 or its components in Windows
    2. Preferably, simply use the Download button below "Disable IPv6" to download an automatic wizard to do it for you
    3. After either running the wizard or manually disabling IPv6, restart your PC
    4. Rejoin the server
    If it still doesn't work...Try Uninstalling VLC Media Player
    We have no idea why VLC messes with codecs/Flash Player, but if you have VLC version 2.2.2 or above, it's likely the issue. Uninstall VLC Media Player and then click here to download VLC version 2.2.1.​
     
    Last edited: Jul 14, 2017
  2. reoko

    reoko New Member

    Joined:
    May 3, 2016
    Messages:
    1
    Likes Received:
    0
    so i did all of this, and I still keep getting this screen on every Kissanime link I put. Everything else seems to be fine, I've only tried Youtube and Twitch, but the kissanime links don't seem to work.
     

    Attached Files:

  3. WinterPhoenix96

    WinterPhoenix96 Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    511
    Likes Received:
    150
    I've updated the original post. Please follow the steps in it to Disable IPv6 and then let me know if it works.
     
    SunsetsAndSushi likes this.
  4. Ross A. Lyghna

    Ross A. Lyghna New Member

    Joined:
    Jun 15, 2016
    Messages:
    1
    Likes Received:
    0
    Hi, I've been experiencing this as well. When I walk into the theatre playing a video, the loading screen and server logo show for a split second before the black screen comes in.The result was the same across all video sites.

    I've done the above: update Adobe Flash using the linked version, and disable IPv6, but to no avail. Restarting Gmod, Steam and even my laptop didn't show any difference.

    For now I'll use another computer and connect to the server to see if it's a problem stemming from my laptop, or something else.
     
  5. Astaroth

    Astaroth New Member

    Joined:
    Dec 31, 2015
    Messages:
    22
    Likes Received:
    14
    Here's my 2 cents on your issue. I had this issue when I went into a theater playing a kissanime video. However, when I went to another theater playing a stream (E3 stream) I had no issues watching videos afterward.

    Also, for those who haven't spent much time on the server, Kissanime is known to not work from time to time causing weird errors and whatnot. Try relying on other video sources like youtube.
     
  6. Pheonix Slayer

    Pheonix Slayer New Member

    Joined:
    Jul 3, 2016
    Messages:
    1
    Likes Received:
    0
    Okay, so I installed the right flash and tried to disable IPv6 using the installer which didn't seem work, so I tried doing it manually do and I'm not sure it's effect
    . Capture.PNG Capture2.PNG
     
  7. WinterPhoenix96

    WinterPhoenix96 Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    511
    Likes Received:
    150
    Do you have VLC Media Player installed?
     
  8. MartzeeFoxX

    MartzeeFoxX New Member

    Joined:
    Jul 3, 2016
    Messages:
    2
    Likes Received:
    0
    While getting ***** stressed trying to figure out why is this happening to me. i wanted to check it out in cereal box(people screaming on my face) if the issue is there too, and **** no, the videos works well. Going back, it was all the time VLC media player like winter said... But the thing is why only on yuki teather? What crazy coding are in yuki that makes vlc media palyer interacts with flash player on yuki teather? Now if I want to use vlc media player I cant cuz.... this dumbest things. What did you do winter??????? I really recommend to restore all the config of cinema, flash or whatever (related with the media player), to its default state. it's just a suggest. I'm sorry i dont mean to be offensive.(if I was......)
     
    Last edited: Jul 3, 2016
  9. WinterPhoenix96

    WinterPhoenix96 Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    511
    Likes Received:
    150
    CBC had the same issue. They chose to solve it by reverting to the New YouTube Player, which makes videos get stuck at 360p. We chose to stay on the Old YouTube Player, as we discovered that it might be VLC and didn't want to break HD video playback just because of that issue.

    So...to put it shortly, it's VLC's crazy programming, not ours.
     
  10. MartzeeFoxX

    MartzeeFoxX New Member

    Joined:
    Jul 3, 2016
    Messages:
    2
    Likes Received:
    0
    oh......
     
  11. CyKL3 | $uicideBoy$

    CyKL3 | $uicideBoy$ New Member

    Joined:
    Jan 7, 2017
    Messages:
    1
    Likes Received:
    0
    I've done everything listed here but it seems like nothing is changing, still black screen :(
     
  12. Miyako

    Miyako New Member Donator

    Joined:
    Jul 1, 2017
    Messages:
    4
    Likes Received:
    0
    I've tried installing Adobe Flash like 5 times over, so that step is done, I uninstalled VLC since I don't use it anyways, and I made sure that IPv6 was gone... Nothing helped. It isn't one site specifically. This happens for KissAnime, YouTube, anything, and it flashes a screen then black.

    Also, on YouTube, it says my browser doesn't support any of the video formats with the YouTube error screen before going to black. How do I solve this, because once I fix the black screen I want to be able to use YouTube on YukiTheater.

    -UPDATE-
    YouTube videos work, but no streams, same error, and no other sites show on my screen.
     
  13. CrossBoy

    CrossBoy New Member Donator

    Joined:
    Jun 24, 2017
    Messages:
    10
    Likes Received:
    1
    Same thing has always happened with me, I dunno
     
  14. WinterPhoenix96

    WinterPhoenix96 Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    511
    Likes Received:
    150
    What's your computer's Operating System?
     
  15. Miyako

    Miyako New Member Donator

    Joined:
    Jul 1, 2017
    Messages:
    4
    Likes Received:
    0
    Windows 10
     
  16. CrossBoy

    CrossBoy New Member Donator

    Joined:
    Jun 24, 2017
    Messages:
    10
    Likes Received:
    1
    Same here
     
  17. WinterPhoenix96

    WinterPhoenix96 Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    511
    Likes Received:
    150
    Alright, join YukiTheater, open the Video Request Menu (F1), click on Web Browser, and paste this URL into its address bar and hit enter:
    Code:
    https://winterphoenix96.github.io/cinema/videotest.html
    It should come up with either a Red or Green webpage that has some text on it. Copy+Paste what the text says and post it here.
     
  18. Miyako

    Miyako New Member Donator

    Joined:
    Jul 1, 2017
    Messages:
    4
    Likes Received:
    0
    Funkmaster already helped me out, but thanks! I just had to install the 2.2.1 version. I hadn't reinstalled aftre deleting, but when i reinstalled it, the streams worked.
     
  19. CrossBoy

    CrossBoy New Member Donator

    Joined:
    Jun 24, 2017
    Messages:
    10
    Likes Received:
    1
    Really late, I know, but either way.