[Cinema / Media System] Black Screens / Videos Not Working

PlayMelZee

New Member
i have tryed everything above but i still can not get the streaming to work. Its just in an infinite refresh loop when i add the stream on the server
 

Attachments

  • infinite loop.jpg
    infinite loop.jpg
    404.8 KB · Views: 10
Last edited:

WinterPhoenix

Founder
Staff member
Founder/Lead Developer
Is there no way to fix video problem in macOS Catalina? PPAPI doesn't work although x86_64 branch says now it includes Chromium.
macOS Catalina should work on x86-64. Flash Player probably will not work though. We're looking into bringing GModCEFCodecFix to macOS and Linux soon, so hopefully that will help.

Until then, in either case, YouTube should work just fine by default.
 

RoyalClodmus

New Member
Donator
I'm getting this error every time i try to run it. I'm using windows ten and this is what it says. tried running it as administrator but the same exact thing happens. [WinError 10013] An attempt was made to access a socket in a way forbidden by its access permissionsoof momento.png
 

WinterPhoenix

Founder
Staff member
Founder/Lead Developer
I'm getting this error every time i try to run it.
As best as I can figure, one of the following is interfering with it:
  • Antivirus Software
  • Windows Firewall
  • Some sort of other web request blocking software like Parental Controls or Blue Coat
The most likely thing is that it's Antivirus. Make sure you don't have McAfee or something preventing it from connecting to the web server.
 
Last edited:

dylanbevan05

New Member
The Fix: x86-64 Branch with CEFCodecFix
To Install, first select your Operating System:
After Trying The Fix, Still Not Working
  1. Completely close GMod and restart it
  2. Make sure you're launching GMod through CEFCodecFix, otherwise Steam might overwrite the patched files
  3. Try Uninstalling VLC Media Player
    • If you have VLC version 2.2.2 or above, it may be causing an issue. Uninstall VLC Media Player and then Reinstall it, unchecking the "Web Plugins" option during setup.
If you find that you're having issues after having tried all of this and have already restarted GMod, reply to this thread and we'll try our best to help.
I setup my steam in a way to install all steam games to a seperate drive instead of the windows system drive, how do i get CEFCodecFix to point to where my gmod location is?
 

MrBiscuits

New Member
it keeps saying bin/html_chromium.dll and bin/win64/html_chromium.dll does not match original. I've verified the files and nothing was wrong. I restarted gmod and that didnt work. I also tried reinstalling gmod and that didnt work either.
 

oski165

New Member
Hi,
I have a problem with the Cinema gamemode even after running this fix. It always gives me the 403 in the console. I tried everything to fix this and no luck.upload_2021-2-3_20-16-59.png
EDIT: I'd like to add that it also won't detect Twitch, but I assume recent changes might be what's causing it
 
Last edited:

WinterPhoenix

Founder
Staff member
Founder/Lead Developer
Hi,
I have a problem with the Cinema gamemode even after running this fix. It always gives me the 403 in the console. I tried everything to fix this and no luck.View attachment 521
EDIT: I'd like to add that it also won't detect Twitch, but I assume recent changes might be what's causing it
Vanilla Cinema doesn't really work anymore, for a number of reasons, including its developers simply no longer being interested on working on it.

See their GitHub Repo for issues just like this: https://github.com/pixeltailgames/cinema/issues

SGS will eventually fix Cinema on a fork. You can follow progress for that here: https://github.com/solsticegamestudios/cinema

Until then, vanilla Cinema will probably continue to not work correctly.
 
Top