GModCEFCodecFix - FAQ

Not open for further replies.


3D Modeler
Staff member
Check out the New Guide Here

Below are the LEGACY FAQ. Please use the new guide above, instead.

Preface: I've seen a lot of people having similar issues with GModCEFCodecFix, so I've decided to make up an FAQ thread to help answer some of the common questions people might be having, mostly regarding troubleshooting issues with the process.
Q: What does this do? Why do I need it?​
This "fix" patches GMod's internal web browser using a custom build of gmod-html, along with a more up-to-date version of Chromium Embedded Framework with proprietary codec support enabled, along with some other small game fixes on macOS and Linux clients to make the game more functional where possible.

This is necessary specifically for the codec and DRM support because many web videos rely on them (Widevine on Netflix is a good example). Even if you don't plan on viewing web videos, you still get benefits from having an updated version of the web browser, too! :)

Q: I have no in-game menu after a GMod update, what happened?​
The game's menu uses CEF to render. Because you had modified CEF files before the update, some of them may have been changed or replaced in the update and now are mismatched. You need to verify your game files via Properties -> Local Files -> Verify Integrity of Game Cache, then run GModCEFCodecFix once again.

Q: GModCEFCodecFix says I have multiple installations of Garry's Mod and fails... how do I fix this?​
Two likely possibilities:

1) You may ACTUALLY have two installations of Garry's Mod in different locations. Steam doesn't like this, neither does the patcher. Remove the second installation of Garry's Mod and the file "appmanifest_4000.acf" from the steamapps directory which contains it.

2) You have remnants of a second Garry's Mod installation somewhere. Remove the remnant files of the second installation. In some cases, you may just need to remove the file "appmanifest_4000.acf" if it is still in the steamapps directory which contained the second installation in the past.

Q: I installed the fix, but suddenly it's not working!!! What gives?​
Sorry! This usually means that Garry's Mod either updated or ran a file validation. If Garry's Mod updated, you might need to validate your GMod files before running GModCEFCodecFix again to solve this issue. Otherwise just run the GModCEFCodecFix application again and your problem should be solved.

Q: Do I really have to launch GMod from the GModCEFCodecFix application?​
No, but you should if you can. This is the best way to avoid problems like the one in the previous question.

Q: Why are you using a different version of CEF than GMod ships with on Windows?​
There are some features in newer Chromium versions that we can leverage within GMod that we otherwise couldn't if we shipped the same version as Garry's Mod. This also has given us a method of "future-proofing" Garry's Mod when/if it stops receiving CEF updates in the future. We can continue to update CEF independently of Garry's Mod updates.

Q: Will other operating systems than Windows get the same support as Windows gets?​
Yes, despite some roadblocks. There are also some features that don't work reasonably well out-of-the-box in GMod's implementation of CEF that we're working to enable and take advantage of in the future.

Q: I have no menu on Linux, what's happening?​
CEF isn't being initialized. This usually means the game doesn't have access to unprivileged usernamespaces. There are two common causes for this:
- You're running GMod/Steam in a container or sandbox which doesn't have access to the kernel configuration that allows for unprivileged usernamespaces. This applies most commonly to things like Flatpak. If you're using the Flatpak version of Steam, please switch to the native Linux packages for your distribution.
- Your kernel does not have unprivileged usernamespaces enabled. This is enabled by default on most distributions running recent versions of the Linux kernel, but some older distros or kernel versions may have this issue. This is usually fixed by running the following in your Terminal application:
sudo sysctl -w kernel.unprivileged_userns_clone=1

This command may differ on some distributions (such as Debian-based systems), but this is the most common one. Search how to enable unprivileged username spaces on your distro if this command doesn't work and you're not using Flatpak Steam.

Q: I have no menu on macOS or the game fails to open on macOS, what's happening?​
CEF isn't being initialized or the patches have not yet been applied. This usually is user error, and may be a result of having the launch option
set. Please remove that launch option and restart the game after.

If you still do not have a menu on macOS (you just see an image slideshow with no logos or text after the loading screen), please contact us, providing us with the following information:
- macOS version
- GModCEFCodecFix output
- chromium.log (Located in steamapps/common/GarrysMod/chromium.log)
- In-game console output

Additionally, validate your game files and attempt to run GModCEFCodecFix to patch the files once again.

Q: I still get a "Does Not Match" error on some files in the Fix application after validating Garry's Mod... what can I do?​
Contact us. This usually means we have to fix the problem on our end. Usually, you'll just need to wait as we have now automated this process more.

Q: I want to remove the changes to my system made by GModCEFCodecFix, how can I do this?​
All that's needed to fully remove GModCEFCodecFix from your system is:
  1. Validate game files via Steam. This removes changes made to the game files.​
  2. Remove the temporary files directory from your operating system's temporary file storage directory.
    - Windows: %localappdata%\Temp\GModCEFCodecFix
    - macOS: /Library/Caches/GModCEFCodecFix
    - Linux: XDG_CACHE_HOME/GModCEFCodecFix​
  3. Delete the GModCEFCodecFix executable.

    For most users, step one will accomplish the desired effect, the other steps are simply to delete all remnants on your storage drive.​
Last edited by a moderator:
Not open for further replies.