1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Can't Queue Lucky☆Star Episodes from MoeTube in YukiTheater

Discussion in 'Bug Reports' started by SunsetsAndSushi, Jul 6, 2016.

Thread Status:
Not open for further replies.
  1. SunsetsAndSushi

    SunsetsAndSushi Member

    Joined:
    Jan 4, 2016
    Messages:
    109
    Likes Received:
    12
    Summary of Issue Encountered:
    When queuing an episode of Lucky☆Star, it says "There was a problem processing the requested video."

    Expected Result:
    Video should queue and start playing on screen.

    Actual Result:
    A blue box appears, stating: "There was a problem processing the requested video."

    Steps to Reproduce:
    1. Copy the link to an episode of Lucky☆Star from MoeTube.
    2. In YukiTheater, open the Video Request Menu.
    3. Paste the episode link into the white box.
    4. Press enter on your keyboard to submit the video request.

    I think this bug is mostly do to the "☆" character in the anime's title. Other anime's from MoeTube will queue just fine, but because of the "☆" in "Lucky☆Star", the link is thrown off and the video request is unable to be processed.

    In my browser, the URL looks like this: http://moetube.net/anime/6084/lucky☆star
    but when you actually copy and paste the link, it looks like this: http://moetube.net/anime/6084/lucky☆star
    The same applies to the episode link requested to be queued. I tried manually replacing the "%E2%98%86" with the "☆" character within the link, but the video was still unable to be processed. This is what lead me to the conclusion that the "☆" character was throwing the entire link off, and it's why I think this bug is probably not fixable.
     
  2. WinterPhoenix

    WinterPhoenix Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    723
    Likes Received:
    268
    Goddammit. It's definitely that. The String Matching Pattern I'm using only alphanumeric characters as well as -, _, and /. It expects nothing else, meaning the link is being interpreted as: /anime/6084/lucky

    That's also why % replacements don't work. I'll stick a Trello Card up for this issue in a sec.
     
  3. WinterPhoenix

    WinterPhoenix Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    723
    Likes Received:
    268
    SunsetsAndSushi likes this.
  4. WinterPhoenix

    WinterPhoenix Founder/Lead Developer Staff Member Founder/Lead Developer

    Joined:
    Dec 28, 2015
    Messages:
    723
    Likes Received:
    268
    This issue is now fixed and will be active the next time the server restarts.
     
    SunsetsAndSushi likes this.
Thread Status:
Not open for further replies.